ruby gem install rails 错误解决

127浏览

ruby gem install rails 错误解决

错误信息:ERROR:Errorinstallingrails:Theatomichttp:///downloadsandfollowtheinstructionsathttp:///oneclick/rubyinstaller/wiki/Development-Kit出错的原因是安装rails的时候,需要buildtools,但系统中没有。

出错信息中同时也给出了解决的法案:1.到http:///downloads/去下载按照http:///oneclick/rubyinstaller/wiki/Development-Kit/安装devkit主要安装步骤如下:1.如果原来系统中已经安装了旧版的devkit,则删除它2.下载上面提到的devkit3.解压下载下来的文件到指定的目录,如c:/devkit。 (注意:目录不能有空格)4,在安装目录下运行,然后按照提示分别运行和来增强ruby5,可以运行geminstallrdiscountplatform=ruby来测试是否成功按照安装步骤,完成了DevKit的安装。

然后,再次安装需要的gem即可.。

您现在的位置:文学网 > 儿童文学

上一篇:第三十四章 心肝宝贝

下一篇:没有了

你可能喜欢的:
友情链接